Technical issues on the side of Ecommpay card acquiring
Incident Report for ECOMMPAY
Resolved
This incident has been resolved.
Posted Oct 10, 2021 - 03:39 UTC
Investigating
We inform you that starting from 04:00 (GMT + 3), you can observe an increase in the number of unsuccessful transactions when making deposits using the 3Ds protocol.
Posted Oct 10, 2021 - 01:43 UTC
This incident affected: Processing Center.